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TSDS SELA Core Collection 
[bookmark: _Toc134534089]TSDS SELA – Submission Purpose, Responsibilities & Requirements
The Special Education Language Acquisition (SELA) collection will report data on the language acquisition of children eight years of age or younger who are deaf or hard of hearing, identified with an auditory impairment or deaf/blind using the following DISABILITY-TYPE codes: ’02’ Deaf-Blindness (Deaf-Blind) or ‘06’ Deaf and Hard of Hearing. 
The StudentSpecialEdProgramAssociationExtension complex type will be used to gather information about language acquisition services being provided to deaf or hard of hearing students.
SELA data consists of two categories: Education Organization and Student. 
The data is reported in three interchanges: InterchangeEducationOrganizationExtension, InterchangeStudentParentExtension, and InterchangeStudentProgramExtension.
Districts will send their SELA data collection through the TSDS Portal in TEAL.
2022-2023 Submission Timeline
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[bookmark: _Toc134534090]TWEDS – TSDS Web-Enabled Data Standards
The data submitted through TSDS must be in XML format as defined in TWEDS (TSDS Web-Enabled Data Standards). The TWEDS is located on the TSDS website.
 http://www.texasstudentdatasystem.org/TSDS/TEDS/TEDS_Latest_Release/
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According to TEDS the LEAs (Local Education Agencies) are responsible for:
· Submitting current, complete, and accurate data for all XML files required for each submission
· Validating and editing data according to the business rules and validations
· Correcting all errors during the validation process
· Delivering “fatal-free” corrected data on or before any due dates set by the ESC or TEA.
[bookmark: _Toc134534091]
TSDS – PEIMS Access and User Roles
The TSDS PEIMS application is only available to authorized ESC, district, and campus staff. A TEAL logon is required as well as access to the Texas Student Data System Portal. Different roles can be assigned to the user based on the access required. There are different roles in the PEIMS application, each with a different level of access.
· ODS Data Loader (ESC/LEA) – This role allows the user to upload PEIMS and TSDS Interchanges to TSDS portal.
· Core LEA Data Promoter (w/SELA Access privilege) – This role allows the user to promote loaded data, validate (prepare) data and view submission data reports.
· Core LEA Data Completer (w/SELA Access privilege) – This role allows the user to promote loaded data, validate (prepare) data, complete (finalize) data and view reports at the district level.
· Core LEA Data Approver (w/SELA Access privilege) (LEA Superintendent) – This role allows the Superintendent to request an extension for the submission. The Superintendent does not approve this submission.
[bookmark: _Toc134534092]Downloading Validation Tool (Current Version 13.0.0)
TEA provides a Validation Tool to validate the format and naming conventions for the PEIMS interchanges. The Validation Tool is in TEAL > Texas Student Data System Portal > 
Utilities for downloading.
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· Click Download Validation Tool to download the tool.
· Click Download Validation Tool Instructions (pdf) to download a copy of the installation instructions.
[bookmark: _Toc134534093]
Validation Tool – Validating PEIMS & TSDS Interchanges
Once the Validation Tool has been downloaded and installed click on the validation tool icon to open the tool.
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· Select File > Validation Tool. The Validation Tool opens in a separate window.
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· Select the School Year 2022-2023.
· Select the TSDS Collection.
· Click the folder icon to browse for and select the TSDS files (files must be unzipped).
· Click Process Files. The results of the validation are reported in the status field.
· If you have files that Fail, you can click on the file name and click the Details button.
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· The Detail Errors page appears, errors can be viewed on screen by selecting Error Type (All, Fatal, Warning, or Special Warning). 
· Errors may also be printed by selecting Print All Errors or saved in Excel format by selecting Export All Errors.
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· Files can be manually loaded in TSDS by clicking on the Open TSDS button. This will take you to the TEAL login screen.
Note: Failed files will not load in TSDS. Files with errors will load, but errors will need to be corrected prior to completing the SELA Submission.
[bookmark: _Toc134534094]
Uploading TSDS files – SELA Data Upload
The TSDS portal is the way to access any of the TSDS applications or utilities to which users have rights. The tabs that appear on the portal depend upon the access that has been granted in TEAL.
The eDM Data Loads tool allows users to load data from their local systems to TSDS.
· Once logged into TEAL, select Texas Student Data System Portal.
· On the Home screen select Manage Data Loads.
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· Under Interchange Menu, select Interchange Upload.
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· Select the 2023 TSDS Interchange Collection from the drop-down menu.
· Click the Browse button for File 1 and select the file from your computer.
· Click the Browse button for File 2 and select the next file from your computer.
· Continue until all required files have been selected.
Note: The files must be loaded in the following order:
· InterchangeEducationOrganizationExtension
· InterchangeStudentParentExtension
· InterchangeStudentProgramExtension
· Click Upload. The files are validated and uploaded to the File Manager.
Note: Files can be zipped for easier upload. Select all files, right click, Send to > Compressed (zipped) folder. Upload the one file.
Do not close this screen while files are uploading. You may exit once the File Manager screen appears.
· Once the files have been completely uploaded, the File Manager screen appears.
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· The files will be processed for errors.
· [image: ]Any failed files with a red X  [image: ] will not batch. To view errors, click on the spyglass and scroll to the bottom of the screen and open the .zip file.
· Any files with errors will have a red X [image: ] in the status column. To view errors, click on the spyglass and scroll to the bottom of the screen and open the .TAB file. 
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· Make all corrections necessary in the software, run the Validation Tool again, and resubmit the files.
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· Once all the files have a green checkmark [image: ] in the status column, select all of the files and click Add to Batch. The View Batch button appears.
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· Select the View Batch button. 
· From the next screen the user may add comments regarding the batch, remove files from the batch, delete files, or process the batch. It is suggested that comments be added naming the file.
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· To remove files from the batch, select the appropriate files and click Remove from Batch.
· The selected file is removed from the View Batch screen but remains in the File Manager.
· To process the batch, select the appropriate files and click Process Batch. The Batch Manager screen appears:
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· The Batch Manager screen appears with a list and status of all batches that have been processed. Batches can have a completed status with errors (red X) or no errors (green checkmark).
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· To view the files with errors, click the spyglass to open the batch and then click on the spyglass next to the file with errors; or
· Click on Download All Error Files.
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· To view the actual errors, click on the spyglass next to the .TAB or ERROR file.
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· Click Cancel to return to previous screens.
· Make corrections as needed in the software, create new interchanges, validate again, and resubmit the files.
[bookmark: _Toc134534095]
Promoting SELA files – Core Collection Promote Loaded Data
The eDM Promote Loaded Data tool allows users to promote data that has been loaded and batched.
· Log in to TEAL and select Texas Student Data System Portal.
· On the Home screen select Promote Loaded Data > SELA.
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· The Data Promotion screen appears:
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· Verify the correct submission is selected. If not, select it from the pull-down menu and click GO.
· From the Categories pull-down menu, select All Categories or the individual categories to be promoted. If individual categories are selected user may also select individual subcategories.
· Enter a Data Promotion Name. 
· Click Next to continue or Reset to clear selections.
· The Confirm Data Promotion screen appears:
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· Verify the Categories/Subcategories
· Click Submit, Cancel, or Back.
· The Monitor Data Promotions screen appears:
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· This screen shows the status of the data promotion, promotion error reports, and a confirmation message that the data was promoted. Wait for Completed status before continuing. 
· To view any promotion errors, click the View link under Error Report or click the LEA Promotion Errors button.
· The Data Load Error Report by Job screen appears:
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· This screen will list any errors by Category, Subcategory, Severity, along with the error message. Errors can be saved as a PDF or XLS file or can be printed by selecting the appropriate button.
[bookmark: _Toc134534096]
Validating SELA files – TSDS Core Promote Loaded Data > Validations
The eDM Promote Loaded Data tool also allows users to validate data that has promoted in TSDS. This is where the district will be able to view the Fatals, Warnings, and Special Warnings for the submission.
· Log in to TEAL and select Texas Student Data System Portal.
· On the Home screen select Promote Loaded Data.
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· Select Validate Submission Data under Validations.
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· From the Categories pull-down menu, select All Categories or the individual categories that are to be validated.
· Select the type of validation (Fatal, Warning, Special Warning).
· Enter a Validation Name.
· Click Next to continue the process or Reset to clear all options.
· The Confirm Data Validation screen appears:
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· Verify the Categories/Subcategories
· Click Submit, Cancel, or Back.
· The Monitor Data Validations screen appears:
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· This screen shows the status of the data validations, validation error reports, and a confirmation message that the data has been submitted. Wait for Completed status before continuing.
· To view validation errors by job, click the LEA Validation Errors button or View und Error Report.
· This screen will list any errors by Category, Subcategory, Severity, along with the error message.
· Errors can be sorted by individual columns. The errors can also be saved as a PDF or XLS file or can be printed by selecting the appropriate button.
· The Search Table option can be used to search the errors by any field such as Rule Number, Student UID, specific Category or Subcategory, etc.
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Note: It is recommended that the district uses the Delete Utility in TSDS > Manage Data Loads to clear the incorrect data from the ODS prior to uploading the new files.
View SELA Report
Reports must be run and verified prior to and after completing the SELA data submission. There currently is only one report available:
· SEL0-100-001 SELA Special Education Language Acquisition Roster
To access the reports:
· Log in to TEAL and select Texas Student Data System Portal.
· On the Home screen select SELA under View Reports. Click View Reports.
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· Or reports can be accessed in Core Collection > SELA > View Reports.
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· Under View Reports, click the arrow in the Run column for the appropriate report.
· The Residential Facilities report requires Parameters be selected. Select the appropriate parameters and click Run.
[image: ]
· Click Download to view the reports.
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[bookmark: _Toc134534097]
Completing SELA Submission – TSDS Core Prepare/Finalize Submission
AT THE END OF THE SCHOOL YEAR DISTRICTS WILL PREPARE/FINALIZE THE SELA SUBMISSION.
Note: The submission cannot be completed if it contains fatal errors.
Before completing the submission, review all reports in the View Reports tab to verify data is accurate. When ready to finalize the submission, confirm that the data status of all subcategories is promoted and validated.
[image: ]
· Click Complete. This prompts another validation of the data. A Completion Process Status message appears showing the progress.
· If there are fatals, the data returns with a status of VALIDATED.
· If there are no fatals, the data returns with a status of COMPLETE.
· A message appears to check the box to acknowledge the data is promoted, validated, reviewed for accuracy and authenticity, and all special warnings and warnings have been reviewed and confirmed. 
· Check the box and click CONFIRM.
[bookmark: _Toc134534098]
Reset Submission
If the data needs to be reset to its original state after completion, click the Reset button.
The user can reset the submission anytime up until TEA’s submission due date. Once the submission is marked complete, the data status is set to LEA – DATA COMPLETE and further edits to the data are not available.
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[bookmark: _Toc134534099]Additional Information
Knowledge Based Articles
TEAL > TSDS > Support > TIMS > Quick Search
SELA:
· TSDSKB-616   SELA: Definition of Assessment Types
· TSDSKB-615   SELA: Definition of Learning Acquisition Services
· TSDSKB-612   SELA: Frequently Asked Questions (FAQ)
[bookmark: _Toc134534100]
Delete Utility
Use the Delete Utility to “clean-up” student SELA data. This utility is used to clear the data in Batch Manager to load new data. 
Note: This is a TSDS submission and deletion of data in TSDS could affect other TSDS collections (ECDS, RFT, etc). Please check with the appropriate personnel before deleting data in TSDS.
Delete Assessment Data:
· Click on Manage Data Loads.
· From the menu, click Delete Utility.
· Click New Delete Request.
· Click the plus sign next to the 2023 TSDS – Data Collection to view the delete options.
· Click the blue arrow for the appropriate option. 
[image: ]
· Type or select any necessary parameters.
· Enter a comment explaining the delete.
[image: ]
· Click Preview Delete. Review and verify the information to be deleted. Click Cancel to cancel the process.
· Click Confirm Delete to perform the deletion.
ESC Region 11 grants permission to attendees of this session to reproduce and distribute designated resources and materials provided during the presentation.
Education Service Center Region 11
1451 S. Cherry Lane
White Settlement, Texas 76108
_________________________________________________________________________________________________
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Business  40100-0204  If age is less than 9 on September 1, and DISABILITY is "Deaf-Blindness (Deaf-Blind)" or

Context "Hearing/Auditory Impairment (Auditory Impairment)", then there must be a Special Education
program association reported with a matching TX-UNIQUE-STUDENT-ID, including
INSTRUCTIONAL-SETTING-CODE, LANG-ACQ-SERVICES-PROVIDED, FREQUENCY-OF-
SERVICES, HOURS-SPENT-RECEIVING-SERVICES, and PREFERRED-HOME-
COMMUNICATION-METHOD.

Students less than nine years of age with the disabilities of "Deaf-Blindness (Deaf-Blind)" or
"Hearing/Auditory Impairment (Auditory Impairment)” must be reported with Special Education
program association Language Acquisition information, including TX-InstructionalSetting, TX-
LangAcqServicesProvided, TX-FrequencyOfServices, TX-HoursSpentServices, and TX-
PreferredHomeCommunicationMethod

Business  40100-0205  If age is less than 9 on September 1, and DISABILITY is "Deaf-Blindness (Deaf-Blind)" or F Y Y Y
Context "Hearing/Auditory Impairment (Auditory Impairment)", then EFFECTIVE-DATE (TX-
EffectiveDateDisabilties) must not be blank.

Students less than nine years of age with the disabilities of "Deaf-Blindness (Deaf-Blind)" or
"Hearing/Auditory Impairment (Auditory Impairment)" must be reported with TX-
EffectiveDateDisabilties.

Business  41163-0057  If HEARING-AMPLIFICATION-TYPE is a value other than blank or "Not Applicable”, then F Y Y Y
Context HEARING-AMPLIFICATION-ACCESS must not be blank.

TX-HearingAmplificationAccess must be reported if TX-HearingAmplificationType is reported as a
value other than blank or "Not Applicable"

Business  41163-0058  If HEARING-AMPLIFICATION-ACCESS is "Full Day", then HEARING-AMPLIFICATION- F Y Y Y
Context AAVERAGE-DAILY-USE must be blank.

TX-HearingAmplifAvgDailyUse must not be reported if TX-HearingAmplificationAccess is "Full
Day"
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Rule Text/
Business Meaning

If HEARING-AMPLIFICATION-ACCESS is "Partial Day”, then HEARING-AMPLIFICATION-
AAVERAGE-DAILY-USE must not be blank

TX-HearingAmplifAvgDailyUse must be reported if TX-HearingAmplificationAccess is "Partial Day"

If HEARING-AMPLIFICATION-AVERAGE-DAILY-USE is not blank, then HEARING-
AMPLIFICATION-ACCESS must be "Partial Day".

TX-HearingAmplificationAccess must be "Partial Day" if TX-HearingAmplifAvgDailyUse is not
blank

1f TOOL-OR-ASSESSMENT-USED is a value other than blank or "Not Assessed", then
ASSESSMENT-RESULTS-OBTAINED must not be blank

TX-AssessmentResultsObtained must be reported if TX-ToolOrAssessmentUsed is reported as a
value other than blank or "Not Assessed”

If LANG-ACQ-SERVICES-PROVIDED is "Services not Provided", then FREQUENCY-OF-
SERVICES must be "None" and HOURS-SPENT-RECEIVING-SERVICES must be "0 Hours".

TX-FrequencyOfServices must be reported as "None" and TX-HoursSpentReceivingServices must
be reported as "0 Hours” when TX-LangAcqServicesProvided is reported as "Services not
Provided"

If FREQUENCY-OF-SERVICES is "None", then LANG-ACQ-SERVICES-PROVIDED must be
"Services not Provided” and HOURS-SPENT-RECEIVING-SERVICES must be "0 Hours".

TX-LangAcqServicesProvided must be reported as "Services not Provided” and TX-
HoursSpentReceivingServices must be reported as "0 Hours" when TX-FrequencyOfServices is
reported as "None"

If HOURS-SPENT-RECEIVING-SERVICES is "0 Hours", then LANG-ACQ-SERVICES-PROVIDED
must be "Services not Provided" and FREQUENCY-OF-SERVICES must be "None™

TX-LangAcgServicesProvided must be reported as "Services not Provided" and TX-
FrequencyOfServices must be reported as "None" when TX-HourseSpentReceivingServices is
reported as "0 Hours"

F Y Y Y
F Y Y Y
F Y Y Y
F Y Y Y
F Y Y Y
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If LANG-ACQ-SERVICES-PROVIDED is "Services not Provided", then this student must not be
reported with any other LANG-ACQ-SERVICES-PROVIDED value

When a student is reported with "Services not Provided" for TX-LangAcqServicesProvided,
indicating that the student did not receive any language acquisition services, then no other TX-
LangAcqServicesProvided may be reported for the student

If HEARING-AMPLIFICATION-TYPE is "Not Applicable”, then this student must not be reported
with any other HEARING-AMPLIFICATION-TYPE value.

When a student is reported with "Not Applicable" for TX-HearingAmplificationType, indicating that
the student does not use a hearing amplification device, then no other TX-
HearingAmplificationType may be reported for the student.

1f TOOL-OR-ASSESSMENT-USED is "Not Assessed”, then this student must not be reported with
any other TOOL-OR-ASSESSMENT-USED value.

When a student is reported with "Not Assessed" for TX-ToolOrAssessmentUsed, then no other TX-
ToolOrAssessmentUsed may be reported for the student

1f TOOL-OR-ASSESSMENT-USED is "Not Assessed", then ASSESSMENT-RESULTS-OBTAINED
must be blank/not reported

TX-AssessmentResultsObtained must be blank/not reported if TX-ToolOrAssessmentUsed is "Not
Assessed"”

If HEARING-AMPLIFICATION-TYPE is "Not Applicable”, then HEARING-AMPLIFICATION-
AACCESS and HEARING-AMPLIFICATION-AVERAGE-DAILY-USE must be blank/not reported.

TX-HearingAmplificationAccess and TX-HearingAmplifAvgDailyUse both must be blankinot
reported if TX-HearingAmplificationType is "Not Applicable”
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